Notice

[Reminder Notification] The product with a target SDK of 30 or higher(Add a guidelines for each IDE)
Dec 16, 2020 (UTC+09:00) View 4729
Dear ONE store developers,

APK Signature Scheme v2 now required.
https://developer.android.com/about/versions/11/behavior-changes-11

- Effective date : Immediately after the deployment of OS11
- Details : 

The notice below only applies to products with a Target sdk of 30 or higher.
We do not force you to upload the SDK version, just sell it according to your product's engine support environment.

1. Apps that target Android 11 (API level 30) that are currently only signed using APK Signature Scheme v1 must now also be signed using APK Signature Scheme v2 or higher. Users can't install or update apps that are only signed with APK Signature Scheme v1 on devices that run Android 11.

2. So, if your binary use ONEstore's SDK(Inapp v16, v17,v19, ALC), Please make sure to declare the following query on Androidmanifest.xml. 

<queries>
    <intent>
        <action android:name="com.onestore.ipc.iap.IapService.ACTION" />
    </intent>
    <intent>
        <action android:name="android.intent.action.VIEW" />
        <data android:scheme="onestore" />
    </intent>
</queries>

3. IDE Response Guidelines
If an app developed with Android platform uses a ONEstore in app, the following tasks are required to use the Android 11<queries>.

(1) Java & Kotlin (Android Studio)

  If TargetSDK is set to 16-29, [Queries] TAG is not required
  If TargetSDK is set to 30, Add a [Queries] TAG in Android Manifest.

(2) Unity

  [Less than 2018.4] 
      [Queries] TAG is not required by setting TargetSDK to less than 30.
  [More than 2018.4 ~ Less than 2020.1]
      If TargetSDK is set to 16-29, [Queries] TAG is not required.
      If TargetSDK is set to 30, raise the Gradle version of Unity Engine to 5.6.4 or later and add [Query] TAG
  [After than 2020.1]
    If TargetSDK is set to 16-29, [Queries] TAG is not required
    If TargetSDK is set to 30, Add a [Queries] TAG in Android Manifest에 [Queries].


(3) Unreal

  Set the Target SDK 16~29. (We'll let you know later.)

(4) Other IDE environment

   Set the Target SDK according to whether or not the Gradle version of the build environment is supported.
       If the build environment does not support Gradle 5.6.4 : Set the between 16 and 29 targetSDK.
       If the build environment does support Gradle 5.6.4 : Set the target SDK to 30, and add a [Queries] TAG in Android Manifest.


Best,

ONEstore dev team.